./archivers/ruby-ffi-libarchive, Ruby FFI binding to libarchive

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.0.17, Package name: ruby26-ffi-libarchive-1.0.17, Maintainer: pkgsrc-users

ffi-libarchive

A Ruby FFI binding to libarchive.


Required to run:
[archivers/libarchive] [lang/ruby26-base]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: 81ee4b483afa4eaa54fa87ac10000710a59a4256
RMD160: 8e248a4ccd6706e704562dd295cd8e33913d26c4
Filesize: 15.5 KB

Version history: (Expand)


CVS history: (Expand)


   2021-02-13 11:13:24 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
archivers/ruby-ffi-libarchive: update to 1.0.17

1.0.17 (2021-02-10)

* Update chefstyle requirement from 1.2.1 to 1.3.2 #35
  (dependabot-preview[bot])
* Update chefstyle requirement from 1.3.2 to 1.4.0 #36
  (dependabot-preview[bot])
* Update chefstyle requirement from 1.4.0 to 1.4.2 #37
  (dependabot-preview[bot])
* Update chefstyle requirement from 1.4.2 to 1.4.3 #38
  (dependabot-preview[bot])
* Update chefstyle requirement from 1.4.3 to 1.4.4 #39
  (dependabot-preview[bot])
* Update chefstyle requirement from 1.4.4 to 1.4.5 #40
  (dependabot-preview[bot])
* Update chefstyle requirement from 1.4.5 to 1.5.0 #41
  (dependabot-preview[bot])
* Update chefstyle requirement from 1.5.0 to 1.5.8 #46
  (dependabot-preview[bot])
* Update chefstyle requirement from 1.5.8 to 1.5.9 #47
  (dependabot-preview[bot])
* Update chefstyle requirement from 1.5.9 to 1.6.1 #48
  (dependabot-preview[bot])
* Test on Ruby 3.0 #49 (tas50)
* Update chefstyle requirement from 1.6.1 to 1.6.2 #50
  (dependabot-preview[bot])
* Extend the reader API to extract to destination #51 (lamont-granquist)
   2020-09-13 16:58:20 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
archivers/ruby-ffi-libarchive: update to 1.0.4

Update ruby-ffi-libarchive to 1.0.4.

v1.0.4 (2020-08-13)

* Optimize requires for non-omnibus installs #34 (tas50)
   2020-08-09 17:03:41 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
archivers/ruby-ffi-libarchive: update to 1.0.3

Update ruby-ffi-libarchive to 1.0.3.

1.0.3 (2020-06-26)

* Optionally clone entries when iterating through an archive #30 (jatoben)
* Replace specific types with more generic equivalents. #32 (phiggins)
* Modern expeditor / buildkite setup #33 (tas50)
   2020-01-18 14:16:10 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
archivers/ruby-ffi-libarchive: update to 1.0.0

Update ruby-ffi-libarchive to 1.0.0.

* Update HOMEPAGE and LICENSE.
* Proper COMMENT.
* No need to use gmake.
* add "USE_LANGUAGES= # none".

1.0.0 (2019-12-28)

* Chefstyle fixes to get the build green again #25 (tas50)
* Add support for custom read functions #27 (jatoben)
* Add Ruby 2.7rc testing and cache gem installs in Buildkite #28 (tas50)
   2019-10-23 18:20:13 by Takahiro Kambe | Files touched by this commit (4)
Log message:
archivers/ruby-ffi-libarchive: add version 0.4.10

Add ruby-ffi-libarchive package version 0.4.10.

ffi-libarchive

A Ruby FFI binding to libarchive.