./chat/libfolks, Library to manage contacts

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.15.5nb2, Package name: libfolks-0.15.5nb2, Maintainer: pkgsrc-users

libfolks is a library that aggregates people from multiple sources (eg,
Telepathy connection managers) to create metacontacts.


Required to run:
[sysutils/dbus-glib] [textproc/libxml2] [devel/glib2] [devel/readline] [chat/telepathy-glib] [devel/libgee] [lang/vala] [devel/gobject-introspection]

Required to build:
[pkgtools/cwrappers] [devel/meson]

Master sites: (Expand)

Filesize: 481.422 KB

Version history: (Expand)


CVS history: (Expand)


   2022-07-22 19:07:15 by Michael Baeuerle | Files touched by this commit (53)
Log message:
*: recursive bump for graphics/graphviz 5.0.0
   2022-04-18 21:12:27 by Adam Ciarcinski | Files touched by this commit (1798) | Package updated
Log message:
revbump for textproc/icu update
   2022-04-03 16:53:04 by Thomas Klausner | Files touched by this commit (1)
Log message:
libfolks: bump ABI depends for shlib major change

nothing in pkgsrc uses this (?!)
   2022-04-03 16:52:16 by Thomas Klausner | Files touched by this commit (3) | Package updated
Log message:
libfolks: update to 0.15.5.

Unstable version, but stable branch doesn't build against
current vala package.

Overview of changes from libfolks 0.15.4 to libfolks 0.15.5
===========================================================

Bugs fixed:
  * vapi: Add missing generic type argument

Overview of changes from libfolks 0.15.3 to libfolks 0.15.4
===========================================================

Bugs fixed:
  * Fix docs build against newer eds version
  * Fix build against newer eds version
  * Remove volatile keyword from tests

Overview of changes from libfolks 0.15.2 to libfolks 0.15.3
===========================================================

Bugs fixed:
  * Fix build against newer eds version

Overview of changes from libfolks 0.15.1 to libfolks 0.15.2
===========================================================

Bugs fixed:
  * Fixed build errors after API version bump
  * Fixed gtk-doc errors due to missing version entities

Overview of changes from libfolks 0.14.0 to libfolks 0.15.1
===========================================================

Dependencies:
  * No more dependencies on libtracker
  * GLib minimal requirement: 0.58
  * E-D-S minimal requirement: 3.38

Major changes:
  * This release drops the Tracker backend (along with its dependencies).
  * A selection of (small) performance improvements
  * Auto-generation and deployment of the docs using CI
   2022-03-30 12:02:27 by Thomas Klausner | Files touched by this commit (47)
Log message:
*: recursive bump for vala 0.56
   2021-12-08 17:07:18 by Adam Ciarcinski | Files touched by this commit (3063)
Log message:
revbump for icu and libffi
   2021-10-26 12:05:29 by Nia Alarie | Files touched by this commit (146)
Log message:
chat: Replace RMD160 checksums with BLAKE2s checksums

All checksums have been double-checked against existing RMD160 and
SHA512 hashes
   2021-10-07 15:23:36 by Nia Alarie | Files touched by this commit (146)
Log message:
chat: Remove SHA1 hashes for distfiles