./databases/php-ldap, PHP extension for LDAP database access

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 7.3.13nb1, Package name: php73-ldap-7.3.13nb1, Maintainer: pkgsrc-users

PHP is a programming language designed to be embedded into web pages.
This module provides access to LDAP databases.


Required to run:
[databases/openldap-client] [lang/php73]

Required to build:
[pkgtools/cwrappers] [devel/pcre2]

Master sites: (Expand)

SHA1: 3c4b349c698b3f515d0f6acc4a72955c4eb075df
RMD160: 72bed7868a6f1144ebfb04434accd92fbdeaec29
Filesize: 11818.371 KB

Version history: (Expand)


CVS history: (Expand)


   2020-01-18 22:51:16 by Jonathan Perkin | Files touched by this commit (1836)
Log message:
*: Recursive revision bump for openssl 1.1.1.
   2017-10-27 10:49:01 by Takahiro Kambe | Files touched by this commit (13) | Package updated
Log message:
pkgsrc: reset PKGREVISION

reset PKGREVISION along with update of all lang/php*.
   2017-07-19 18:20:07 by Emmanuel Dreyfus | Files touched by this commit (3)
Log message:
Add php70 and php71 patches for the exop option

The LDAP controls and extended operations (EXOP) has been merged upstream
with some modifications. The patches backports upstream code to php70
and php71, with additionnal EXOP REFRESH support that is missing for now.
   2017-05-12 10:28:12 by Emmanuel Dreyfus | Files touched by this commit (3) | Package updated
Log message:
Update the LDAP EXOP patch to build with PHP 5.6.x
Remove the versions for retired PHP 5.4 and 5.5
   2016-04-02 11:05:23 by Takahiro Kambe | Files touched by this commit (9)
Log message:
Reset PKGREVISION after all PHP language packages.
   2016-03-05 12:29:49 by Jonathan Perkin | Files touched by this commit (1813) | Package updated
Log message:
Bump PKGREVISION for security/openssl ABI bump.
   2015-11-08 10:25:27 by Emmanuel Dreyfus | Files touched by this commit (2) | Package updated
Log message:
Let ldap_sasl_bind() use interractive input

Interractive methods such as OTP use the ldap_sasl_bind() callback with
SASL_CB_ECHOPROMPT or SASL_CB_ECHONOPROMPT instead of SASL_CB_PASS. Add
the cases and treat them like SASL_CB_PASS for PHP 5.4.x and PHP 5.5.x.
The exop patch for PHP 5.6.x is broken right now and will be updated later.
   2015-05-16 13:19:53 by Takahiro Kambe | Files touched by this commit (4) | Package updated
Log message:
Reset PKGREVISION along with php{54,55,56} update.