./devel/at-spi2-core, Assistive Technology Service Provider Interface Core

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 2.40.3nb2, Package name: at-spi2-core-2.40.3nb2, Maintainer: prlw1

This package provides the core of the Assistive Technology Service
Provider Interface, in particular the registry daemon with which
AT applications such as screen readers can listen for events
broadcast by accessible programs; and also a library, libatspi, to
assist in writing AT applications. This "version 2" uses DBUS
rather than CORBA for inter-application communication.


Required to run:
[sysutils/dbus] [devel/glib2] [x11/libXtst] [devel/gobject-introspection] [lang/python37]

Required to build:
[pkgtools/x11-links] [pkgtools/cwrappers] [x11/xorgproto] [devel/meson]

Master sites: (Expand)

Filesize: 192.898 KB

Version history: (Expand)


CVS history: (Expand)


   2022-08-09 14:08:36 by Jonathan Perkin | Files touched by this commit (72)
Log message:
*: Remove hardcoded -liconv / -lintl on SunOS.

This is now handled centrally via OPSYS_EXPLICIT_LIBDEPS support in libiconv
and gettext-lib.
   2022-07-29 18:29:09 by Jonathan Perkin | Files touched by this commit (15) | Package updated
Log message:
*: Explicitly pass -lintl on SunOS where required.

Recent libtool update appears to have exposed more of these.
   2022-06-07 22:45:56 by Thomas Klausner | Files touched by this commit (1)
Log message:
at-spi2-core: gobject-introspection is a build dependency

Bump PKGREVISION.
   2021-12-08 17:07:18 by Adam Ciarcinski | Files touched by this commit (3063)
Log message:
revbump for icu and libffi
   2021-10-26 12:20:11 by Nia Alarie | Files touched by this commit (3016)
Log message:
archivers: Replace RMD160 checksums with BLAKE2s checksums

All checksums have been double-checked against existing RMD160 and
SHA512 hashes

Could not be committed due to merge conflict:
devel/py-traitlets/distinfo

The following distfiles were unfetchable (note: some may be only fetched
conditionally):

./devel/pvs/distinfo pvs-3.2-solaris.tgz
./devel/eclipse/distinfo eclipse-sourceBuild-srcIncluded-3.0.1.zip
   2021-10-07 15:44:44 by Nia Alarie | Files touched by this commit (3017)
Log message:
devel: Remove SHA1 hashes for distfiles
   2021-04-12 15:07:44 by Nia Alarie | Files touched by this commit (1)
Log message:
at-spi2-core: set PYTHON_FOR_BUILD_ONLY
   2020-10-01 13:45:46 by Patrick Welche | Files touched by this commit (2)
Log message:
Update at-spi2-core to 2.38.0

What's new in at-spi2-core 2.37.92:

* Fix a possible memory leak if an event name cannot be parsed.

* _atspi_dbus_set_interfaces: fix memory leak when called with an invalid
  DBus signature.

* Fix a crash if an event listener is removed during an event callback.

What's new in at-spi2-core 2.37.90:

* Add a mode-changed signal to allow a screen reader to indicate
  that its mode has changed.

* Fix use after free when a device listener is destroyed (#22).

* Meson: de-duplicate deps of 'Requires' in pkgconfig file (!28).

* Fix use after free when an event listener is destroyed.

* Make at-spi-dbus-bus.desktop validate (!30).

* atspi_accessible_set_cache_mask: relax assert that was generating a
  warning and causing the function to fail in some cases.

* Fixes for synthesizing keys.

* Fix Qt annotations in DBus xml files.

* Memory test: replace gedit with a light-weight test application.

* dbtest: print to stdout instead of stderr.

* Tests: make test a bit verbose.

* Constants: fix typos in two _COUNT constants.