./devel/ocaml-core, Standard library overlay for OCaml by Jane Street

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.13.0, Package name: ocaml-core-0.13.0, Maintainer: jaapb

Core is an industrial-strength alternative to the OCaml standard library.
It was developed by Jane Street, which is the largest industrial user of OCaml.


Required to run:
[lang/ocaml] [devel/ocaml-sexplib] [devel/ocaml-dune] [devel/ocaml-jst-config] [devel/ocaml-core_kernel] [devel/ocaml-ppx_jane] [devel/ocaml-spawn]

Required to build:
[pkgtools/cwrappers] [misc/ocaml-opaline]

Master sites:

SHA1: 326679d75deb784935c2f6844290988c565929fb
RMD160: 2010351f6154fd20a5b367a83366b0dab8a2027d
Filesize: 678.654 KB

Version history: (Expand)


CVS history: (Expand)


   2020-01-17 10:33:45 by Jaap Boender | Files touched by this commit (5) | Package updated
Log message:
Updated devel/ocaml-core to version 0.13.0.

The changelog hasn't been updated, but this version definitely adds
support for OCaml 4.09.
   2019-07-01 14:38:53 by Jaap Boender | Files touched by this commit (3) | Package updated
Log message:
Updated devel/ocaml-core to version 0.12.3.

This adds support for Ocaml 4.08 and fixes a linking bug.
With this update, PR pkg/54330 should also be fixed.
   2019-03-25 10:14:48 by Jaap Boender | Files touched by this commit (6)
Log message:
Added devel/ocaml-core, standard library overlay for OCaml