./devel/ocaml-core_kernel, OCaml standard library overlay (kernel)

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.13.1, Package name: ocaml-core_kernel-0.13.1, Maintainer: jaapb

Core is an industrial-strength alternative to the OCaml standard library.
It was developed by Jane Street, which is the largest industrial user of OCaml.

Core_kernel is the system-independent part of Core.


Required to run:
[lang/ocaml] [devel/ocaml-findlib] [devel/ocaml-sexplib] [devel/ocaml-ppx_sexp_conv] [devel/ocaml-base] [devel/ocaml-stdio] [devel/ocaml-ppx_hash] [devel/ocaml-ppx_base] [devel/ocaml-dune] [devel/ocaml-ppx_sexp_message] [devel/ocaml-ppx_assert] [devel/ocaml-fieldslib] [devel/ocaml-base_quickcheck] [devel/ocaml-splittable_random] [devel/ocaml-ppx_inline_test] [devel/ocaml-bin_prot] [devel/ocaml-variantslib] [devel/ocaml-jane-street-headers] [devel/ocaml-jst-config] [time/ocaml-time_now] [devel/ocaml-typerep] [devel/ocaml-ppx_jane] [devel/ocaml-base_bigstring]

Required to build:
[pkgtools/cwrappers] [misc/ocaml-opaline]

Master sites:

SHA1: dfcaf18cf6bfe24170fdc330c7801845af395357
RMD160: 150319ff503552bc3d94943140d536405cedf0cf
Filesize: 623.758 KB

Version history: (Expand)


CVS history: (Expand)


   2020-04-03 13:56:31 by Jaap Boender | Files touched by this commit (3) | Package updated
Log message:
Updated devel/ocaml-core_kernel to version 0.13.1.

This adds support for OCaml 4.10.
   2020-01-16 16:31:16 by Jaap Boender | Files touched by this commit (23) | Package updated
Log message:
Updated devel/ocaml-core_kernel to version 0.13.0.

This version mostly includes minor improvements and bugfixes. See the
changelog for more details.
   2019-11-03 11:39:32 by Roland Illig | Files touched by this commit (274)
Log message:
devel: align variable assignments

pkglint -Wall -F --only aligned --only indent -r

No manual corrections.
   2019-06-11 11:06:33 by Jaap Boender | Files touched by this commit (3) | Package updated
Log message:
Updated devel/ocaml-core_kernel to version 0.12.2.

This adds support for OCaml 4.08.
I have also added bash to USE_TOOLS to fix PR pkg/54285.
   2019-03-25 10:38:57 by Jaap Boender | Files touched by this commit (7)
Log message:
Removed comments in ocaml Makefiles for now-added dependencies
   2019-03-21 15:56:45 by Jaap Boender | Files touched by this commit (6)
Log message:
Temporarily disabling missing dependencies, will fix ASAP
   2019-03-19 11:07:48 by Jaap Boender | Files touched by this commit (14)
Log message:
Added devel/ocaml-core_kernel, standard library overlay (kernel)