./devel/py-flake8-docstrings, Extension for flake8 using pydocstyle to check docstrings

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.5.0, Package name: py37-flake8-docstrings-1.5.0, Maintainer: minskim

A simple module that adds an extension for the pydocstyle tool to
flake8.


Required to run:
[devel/py-setuptools] [devel/py-flake8] [devel/py-docstyle] [lang/python37]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: b393ba86615182225745dffb2acfd1b08268681d
RMD160: bb6627e8a4166889e86e1641003ffa385c3c69d5
Filesize: 5.541 KB

Version history: (Expand)


CVS history: (Expand)


   2019-10-22 08:51:54 by Adam Ciarcinski | Files touched by this commit (2) | Package updated
Log message:
py-flake8-docstrings: updated to 1.5.0

1.5.0

- Add --ignore-decorators option which allows functions with a specific
  decorator to ignore error codes.

1.4.0

- Add --docstring-convention option which allows selection of conventions
  besides the default pep257.  Available options are based on those
  available from pydocstyle and are currently pep257, google, and
  numpy.  flake8-docstrings also adds a special all docstring
  convention which will enable all rules from pydocstyle.  Note that
  pydocstyle defines some conflicting rules so you'll want to use
  ignore / extend-ignore when selecting docstring-convention = all

- Bump minimum flake8 version to 3

- Fix proper handling of stdin via --stdin-display-name
   2018-07-09 04:06:50 by Min Sik Kim | Files touched by this commit (4)
Log message:
devel/py-flake8-docstrings: Import version 1.3.0

A simple module that adds an extension for the pydocstyle tool to
flake8.