NOTICE: This package has been removed from pkgsrc

./devel/rake, Ruby Make

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ]


Branch: CURRENT, Version: 0.8.7nb2, Package name: ruby18-rake-0.8.7nb2, Maintainer: taca

Rake is a simple ruby build program with capabilities similar to make.
Rake has the following features:

* Rakefiles (rake's version of Makefiles) are completely defined in
standard Ruby syntax. No XML files to edit. No quirky Makefile
syntax to worry about (is that a tab or a space?)
* Users can specify tasks with prerequisites.
* Rake supports rule patterns to sythesize implicit tasks.
* Rake is lightweight. It can be distributed with other projects as
a single file. Projects that depend upon rake do not require that
rake be installed on target systems.


Required to run:
[misc/rubygems] [lang/ruby18-base]

Required to build:
[misc/rubygems]

Master sites:

SHA1: 91daad079d404b68a7dd179716b9fdd0c195144c
RMD160: 1c41208b3bf8fba5a89a7b156eb862c4cf6278f0
Filesize: 102.5 KB

Version history: (Expand)


CVS history: (Expand)


   2012-03-17 14:53:46 by Takahiro Kambe | Files touched by this commit (5) | Package removed
Log message:
Remove devel/rake moved to ruby-rake.
   2012-03-17 14:48:04 by Takahiro Kambe | Files touched by this commit (1)
Log message:
Remove delete patch-ab file's entry.
   2012-03-03 08:41:07 by Takahiro Kambe | Files touched by this commit (2)
Log message:
Use OVERRIDE_GEMSPEC to modify gemspec file instead of patch.
   2011-08-12 18:01:39 by Takahiro Kambe | Files touched by this commit (3) | Package updated
Log message:
Reduce patch file since newer rubygems handles gemspec better.

Bump PKGREVISION.
   2010-11-04 13:23:41 by OBATA Akio | Files touched by this commit (1)
Log message:
Fixes CONFLICTS pattern, or cannot co-install with any rake-XXXX packags.
   2010-09-13 16:32:42 by Takahiro Kambe | Files touched by this commit (17)
Log message:
* Add CONFLICTS a pattern matches previous package name
  without "${RUBY_PKGPREFIX}-".
   2010-09-10 07:05:40 by Takahiro Kambe | Files touched by this commit (4) | Package updated
Log message:
Oops, I forgot to commit update patch, PLIST and to add ALTERNATIVES.
   2010-09-10 05:54:51 by Takahiro Kambe | Files touched by this commit (1) | Package updated
Log message:
Adjust devel/rake to new ruby package's framework.

* Add LICENSE.
* Update HOMEPAGE.
* Installing command name to rake${RUBY_VER} == ruby18.

Bump PKGREVISION.