./games/chocolate-doom, Doom/Heretic/Hexen/Strife source port

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 3.0.1nb9, Package name: chocolate-doom-3.0.1nb9, Maintainer: pkgsrc-users

Chocolate Doom aims to accurately reproduce the original DOS version of
Doom and other games based on the Doom engine in a form that can be
run on modern computers.

Originally, Chocolate Doom was only a Doom source port. The project
now includes ports of Heretic and Hexen, and Strife.

Chocolate Doom's aims are:

* To always be 100% Free and Open Source software.
* Portability to as many different operating systems as possible.
* Accurate reproduction of the original DOS versions of the games,
including bugs.
* Compatibility with the DOS demo, configuration and savegame files.
* To provide an accurate retro "feel" (display and input should
behave the same).

This is a game engine - the data files are not included.


Required to run:
[sysutils/desktop-file-utils] [graphics/hicolor-icon-theme] [graphics/png] [audio/libsamplerate] [devel/SDL2] [audio/SDL2_mixer] [net/SDL2_net]

Required to build:
[pkgtools/x11-links] [x11/xcb-proto] [x11/fixesproto4] [pkgtools/cwrappers] [x11/xorgproto] [lang/python37]

Master sites:

Filesize: 2456.04 KB

Version history: (Expand)


CVS history: (Expand)


   2024-01-30 15:22:43 by Ryo ONODERA | Files touched by this commit (672)
Log message:
*: Recursive revbump from audio/pulseaudio-17.0
   2023-08-14 07:25:36 by Thomas Klausner | Files touched by this commit (1247)
Log message:
*: recursive bump for Python 3.11 as new default
   2023-05-06 21:09:54 by Ryo ONODERA | Files touched by this commit (687)
Log message:
*: Recursive revbump from audio/libopus 1.4
   2022-09-11 14:52:13 by Thomas Klausner | Files touched by this commit (670)
Log message:
*: bump PKGREVISION for flac shlib bump
   2022-08-11 07:09:36 by David H. Gutteridge | Files touched by this commit (999)
Log message:
Bump all dependent packages of wayland (belatedly)

The package changed with the addition of its libepoll-shim dependency.
Otherwise, we can get:
ERROR: libepoll-shim>=0.0.20210418 is not installed; can't buildlink files.
   2022-03-28 12:44:25 by Tobias Nygren | Files touched by this commit (163)
Log message:
g*/*: revbump(1) for libsndfile
   2021-12-08 17:07:18 by Adam Ciarcinski | Files touched by this commit (3063)
Log message:
revbump for icu and libffi
   2021-10-26 12:44:37 by Nia Alarie | Files touched by this commit (466)
Log message:
games: Replace RMD160 checksums with BLAKE2s checksums

All checksums have been double-checked against existing RMD160 and
SHA512 hashes