./games/openjk, Community version of the Star Wars: Jedi Academy game engine

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.0.0.20191030nb1, Package name: openjk-0.0.0.20191030nb1, Maintainer: pkgsrc-users

OpenJK is an effort by the JACoders group to maintain and improve the game
engine on which the Star Wars: Jedi Academy game runs on, while maintaining
full backwards compatibility with the existing game. This project does not
attempt to rebalance or otherwise modify core gameplay.

You will need a copy of Jedi Academy to play OpenJK.


Required to run:
[sysutils/desktop-file-utils] [graphics/hicolor-icon-theme] [graphics/png] [graphics/jpeg] [graphics/glu] [devel/SDL2] [audio/openal-soft]

Required to build:
[pkgtools/x11-links] [x11/xcb-proto] [x11/fixesproto4] [pkgtools/cwrappers] [x11/xorgproto]

Master sites:


Version history: (Expand)


CVS history: (Expand)


   2020-03-08 17:51:54 by Thomas Klausner | Files touched by this commit (2833)
Log message:
*: recursive bump for libffi
   2019-11-03 13:12:56 by Nia Alarie | Files touched by this commit (8)
Log message:
Add games/openjk.

OpenJK is an effort by the JACoders group to maintain and improve the game
engine on which the Star Wars: Jedi Academy game runs on, while maintaining
full backwards compatibility with the existing game. This project does not
attempt to rebalance or otherwise modify core gameplay.

You will need a copy of Jedi Academy to play OpenJK.