./misc/ruby-commander, The complete solution for Ruby command-line executables

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 4.6.0, Package name: ruby27-commander-4.6.0, Maintainer: pkgsrc-users

The complete solution for Ruby command-line executables. Commander bridges the
gap between other terminal related libraries you know and love (OptionParser,
HighLine), while providing many new features, all packed in one simple, elegant
API.


Required to run:
[devel/ruby-highline] [lang/ruby26-base]

Required to build:
[pkgtools/cwrappers]

Master sites:

Filesize: 37.5 KB

Version history: (Expand)


CVS history: (Expand)


   2021-10-26 12:59:39 by Nia Alarie | Files touched by this commit (378)
Log message:
misc: Replace RMD160 checksums with BLAKE2s checksums

All checksums have been double-checked against existing RMD160 and
SHA512 hashes

The following distfiles could not be fetched (possibly fetched
conditionally?):

./misc/libreoffice/distinfo libreoffice/harfbuzz-2.6.4.tar.xz
   2021-10-07 16:35:55 by Nia Alarie | Files touched by this commit (378)
Log message:
misc: Remove SHA1 hashes for distfiles
   2021-05-04 17:30:16 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
misc/ruby-commander: update to 4.6.0

4.6.0 (2021-04-09)

* Fix error with SortedSet on Ruby 3.0 (#98).
* Remove `#reset_io` as it didn't do anything.
* Drop support for Ruby < 2.4.
   2020-03-23 17:37:12 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
misc/ruby-commander: update to 4.5.2

Update ruby-commander to 4.5.2.
pkgsr change: add "USE_LANGAUGES=	# none".

=== 4.5.2 / 2020-03-12

* Fix bug handling global options provided in option=value form (#47). (@orien)
* Fix ERB warnings under Ruby 2.7. (@esotericpig)
* Fix bug handling global options placed before command name (#32). (@orien)

=== 4.5.1 / 2020-03-08

* Fix bug causing global options to be ignored when arguments are present (#86). \ 
(@orien)

=== 4.5.0 / 2020-01-21

* Drop support for Ruby < 2.3.
* Fix bug parsing double dash (#75).

4.4.7 / 2018-10-22

* Update HighLine dependency to 2.0.0. (@rohitpaulk)
   2018-09-23 17:46:43 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
misc/ruby-commander: update to 4.4.6

=== 4.4.6 / 2018-07-31

* Fix unexpected internal behavior change introduced in 4.4.5.
   2018-06-25 07:48:13 by Takahiro Kambe | Files touched by this commit (1)
Log message:
misc/ruby-commander: Fix dependency

Correct dependency to ruby-highline17.
   2018-06-24 16:19:40 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
misc/ruby-commander: update to 4.4.5

* pkgsrc change: change dependency to devel/ruby-highline17.

=== 4.4.5 / 2018-05-22

* Make internal command state less mutable. (@doriantaylor)
   2018-03-14 15:54:32 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
misc/ruby-commander: update to 4.4.4

=== 4.4.4 / 2018-01-18

* Fix deprecated constant warnings on Ruby 2.5. (@mattbrictson)