./misc/ruby-launchy, Ruby class for launching applications

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 2.5.0, Package name: ruby26-launchy-2.5.0, Maintainer: pkgsrc-users

Launchy is helper class for launching cross-platform applications in
a fire and forget manner.

There are application concepts (browser, email client, etc.) that are
common across all platforms, and they may be launched differently on
each platform. Launchy is here to make a common approach to launching
external application from within Ruby programs.


Required to run:
[net/ruby-addressable] [lang/ruby26-base]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: 413a20b7d777e2bfee8a98170c4033e6977b6bbd
RMD160: 523d6ff316013c78f5a9b8783fa309d4c8d35331
Filesize: 29.5 KB

Version history: (Expand)


CVS history: (Expand)


   2020-03-23 17:49:31 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
misc/ruby-launchy: update to 2.5.0

Update ruby-launchy to 2.5.0.
pkgsrc change: add "USE_LANGAUGES=	# none".

## Version 2.5.0 - 2020-02-27

* Update depedencies
* Update minimum ruby level
* Move to `kde-open` on KDE - \ 
<https://github.com/copiousfreetime/launchy/pull/105> - wstephenson
* Applied some grammer / spelling fixes - \ 
<https://github.com/copiousfreetime/launchy/pull/130> - jeremymoritz
* `Pathname` instances do not raise exceptions when opening local files - \ 
<https://github.com/copiousfreetime/launchy/issues/101> - dmke
* Add a fallback console browsers - \ 
<https://github.com/copiousfreetime/launchy/issues/93> - trejkaz
   2019-11-18 17:20:23 by Takahiro Kambe | Files touched by this commit (6)
Log message:
Remove USE_RAKE

Remove USE_RAKE.  It was used to control dependency to ruby-rake package
befor ruby 2.0 days.  Now all ruby*-base package contains rake command and
USE_RAKE is already not used in any where.
   2016-11-19 15:38:04 by Takahiro Kambe | Files touched by this commit (6)
Log message:
Remove RUBY_RDOC_VERSION since All RUBY_VERSION_DEFAULT versions of Ruby
are satisfy minimum RUBY_RDOC_VERSION now.
   2015-11-04 00:49:56 by Alistair G. Crooks | Files touched by this commit (330)
Log message:
Add SHA512 digests for distfiles for misc category

Problems found locating distfiles:
	Package colorls: missing distfile ls.tar.gz
	Package molden: missing distfile molden-4.6/molden4.6.tar.gz
	Package softmaker-office-demo: missing distfile ofl06trial.tgz

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-02-04 16:27:06 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
Update ruby-launchy to 2.4.3.

## Version 2.4.3 - 2014-11-03
* Update documentation - \ 
<https://github.com/copiousfreetime/launchy/pull/81> - supremebeing7
* Fix launching of `exo-open` for XFCE - \ 
<https://github.com/copiousfreetime/launchy/issues/82> - dsandstrom
* Add iceweasel as a fallback browser - \ 
<https://github.com/copiousfreetime/launchy/pull/92> -  jackturnbull
* Reopen $stderr in really bad situation - \ 
<https://github.com/copiousfreetime/launchy/pull/77> - infertux
   2014-01-17 19:13:34 by Izumi Tsutsui | Files touched by this commit (3) | Package updated
Log message:
Update ruby-launchy to 2.4.2.  Part of PR/48447.

pkgsrc change:
Update HOMEPAGE per http://rubygems.org/gems/launchy (the old page is 403)

Changes from HISTORY.md:

## Version 2.4.2 - 2013-11-28
* Fix kde issue - <https://github.com/copiousfreetime/launchy/issues/72> - \ 
colbell

## Version 2.4.1 - 2013-11-26
* Abstract out the argv of the commandline - \ 
<https://github.com/copiousfreetime/launchy/issues/71>

## Version 2.4.0 - 2013-11-12
* Support `Launchy.open( url, :debug => true )` - \ 
<http://github.com/copiousfreetime/launchy/issues/63> - schmich
* Fix inconsistencies in `debug?` and `dry_run?` methods - \ 
<http://github.com/copiousfreetime/launchy/issues/63> - schmich
* Fix detection of missing *nix desktops - \ 
<http://github.com/copiousfreetime/launchy/issues/70>
* Fix running tests in bare Linux environment - \ 
<http://github.com/copiousfreetime/launchy/issues/67> - gioele
* Fix mistaking windows drive as uri schema - \ 
<http://github.com/copiousfreetime/launchy/issues/65>
* Attempt fixing windows `start` command oddities, again - \ 
<http://github.com/copiousfreetime/launchy/issues/62>
   2013-09-15 16:10:09 by Takahiro Kambe | Files touched by this commit (3) | Package updated
Log message:
Update ruby-launchy to 2.3.0.

## Version 2.3.0 - 2013-04-11

* Add the option to call a block on error instead of raising an exception
   2013-02-27 04:58:12 by Takahiro Kambe | Files touched by this commit (1) | Package updated
Log message:
Add correct dependency to ruby-rdoc.

Since dependency has also changed with ruby193, bump PKGREVISION.