./print/atril, Simple multi-page document viewer for the MATE environment

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.22.3nb1, Package name: atril-1.22.3nb1, Maintainer: youri

Atril is a document viewer capable of displaying
multiple and single page document formats like PDF
and Postscript.

Atril is a fork of Evince


Required to run:
[sysutils/desktop-file-utils] [sysutils/dbus-glib] [textproc/libxml2] [print/poppler-glib] [graphics/djvulibre-lib] [graphics/hicolor-icon-theme] [graphics/tiff] [security/openssl] [devel/glib2] [print/libspectre] [graphics/gdk-pixbuf2] [x11/gtk3] [print/libgxps] [security/libsecret] [x11/mate-desktop] [sysutils/caja] [lang/python37]

Required to build:
[pkgtools/x11-links] [x11/xcb-proto] [x11/fixesproto4] [pkgtools/cwrappers] [lang/gcc5] [x11/xorgproto]

Package options: dbus, djvu, gdk-pixbuf, keyring, pdf, ps, tiff, xps

Master sites:

SHA1: 0cb36ea00c3f5937ffa9209dc89840c894acfd49
RMD160: 1ef333b16ac811de5c054c92f8ac69e16ba6b88c
Filesize: 1756.246 KB

Version history: (Expand)


CVS history: (Expand)


   2020-01-18 22:51:16 by Jonathan Perkin | Files touched by this commit (1836)
Log message:
*: Recursive revision bump for openssl 1.1.1.
   2019-12-16 05:08:11 by David H. Gutteridge | Files touched by this commit (3) | Package updated
Log message:
atril: update to 1.22.3

Change log:

### atril 1.22.3

  * update translations
  * libview: fixing memory leak
  * Revert "First page should not reloaded"
  * libview: Reset `pressed_button` when starting Drag and Drop

### atril 1.22.2

  * update translations
  * fixed greek translation for user guide
  * prevent segfaults when no document loaded
  * Fix buffer overflow in backend/tiff-document.c
   2019-11-07 13:38:09 by Thomas Klausner | Files touched by this commit (41) | Package updated
Log message:
*: recursive bump for poppler update to 0.82.0
   2019-10-28 22:49:22 by Maya Rashish | Files touched by this commit (2) | Package updated
Log message:
atril: don't enable dvi support by default. bump pkgrevision.

This option is pulling in t1lib. t1lib is an enormous security risk.
It hasn't seen maintenance since 2011 and we have local patches for
security issues from 2011.

Given the lack of attention, it's likely there are more security
issues lurking.

Documents are usually obtained from untrusted sources, and thus are
considered a remote attack vector
Documents may embed their own fonts. If one embeds a T1 font, it might
be parsed by this unmaintained library.

To avoid this risk, rip out the t1lib dependency.
   2019-10-19 14:46:08 by Nia Alarie | Files touched by this commit (36)
Log message:
Recursive revbump for poppler 0.81.0
   2019-07-23 19:20:01 by Thomas Klausner | Files touched by this commit (43)
Log message:
*: recursive bump for poppler 0.79
   2019-07-22 00:26:08 by Thomas Klausner | Files touched by this commit (1256)
Log message:
*: recursive bump for gdk-pixbuf2-2.38.1
   2019-07-21 00:46:59 by Thomas Klausner | Files touched by this commit (595)
Log message:
*: recursive bump for nettle 3.5.1