./security/php-ssdeep, PHP extension for ssdeep

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.1.0, Package name: php73-ssdeep-1.1.0, Maintainer: khorben

The ssdeep project page describes it as a library for "...computing context
triggered piecewise hashes (CTPH). Also called fuzzy hashes, CTPH can match
inputs that have homologies. Such inputs have sequences of identical bytes in
the same order, although bytes in between these sequences may be different in
both content and length".

For an in depth paper explaining context triggered piecewise hashes please see
http://dfrws.org/2006/proceedings/12-Kornblum.pdf


Required to run:
[security/ssdeep] [lang/php56]

Required to build:
[pkgtools/cwrappers]

Master sites:


Version history: (Expand)


CVS history: (Expand)


   2021-01-03 08:36:43 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
php-ssdeep: update to 1.1.0

pkgsrc change: remove restriction to PHP versions.

1.1.0 (2018-02-20)

* Patch for PHP 7 support (remicollet)
* Add basic Windows support (weltling)
   2020-01-19 00:36:14 by Roland Illig | Files touched by this commit (3046)
Log message:
all: migrate several HOMEPAGEs to https

pkglint --only "https instead of http" -r -F

With manual adjustments afterwards since pkglint 19.4.4 fixed a few
indentations in unrelated lines.

This mainly affects projects hosted at SourceForce, as well as
freedesktop.org, CTAN and GNU.
   2016-09-11 19:03:29 by Takahiro Kambe | Files touched by this commit (53)
Log message:
Drop "55" (php55) from PHP_VERSIONS_ACCEPTED.
   2015-12-19 15:27:15 by Takahiro Kambe | Files touched by this commit (26)
Log message:
Restrict PHP_VERSIONS_ACCEPTED to 55 and 56.
   2015-11-04 02:18:12 by Alistair G. Crooks | Files touched by this commit (434)
Log message:
Add SHA512 digests for distfiles for security category

Problems found locating distfiles:
	Package f-prot-antivirus6-fs-bin: missing distfile fp-NetBSD.x86.32-fs-6.2.3.tar.gz
	Package f-prot-antivirus6-ws-bin: missing distfile fp-NetBSD.x86.32-ws-6.2.3.tar.gz
	Package libidea: missing distfile libidea-0.8.2b.tar.gz
	Package openssh: missing distfile openssh-7.1p1-hpn-20150822.diff.bz2
	Package uvscan: missing distfile vlp4510e.tar.Z

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-08-30 16:52:39 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
Update php-ssdeep to 1.0.4.

1.0.4
This is a build maintenance release only so there is no need to upgrade.

- Make use of --with-libdir so installers can override the lib default (RHEL
  uses lib64 for example)
- Clean up the build script to standardise the code constructs used
- Add LICENSE, README and CREDITS to PECL package configuration

1.0.3
Bug #60347 OSX can't build as .so hardcoded
   2013-06-11 03:12:23 by Pierre Pronchery | Files touched by this commit (1)
Log message:
Hopefully fixes building on most platforms supported
   2013-06-05 21:57:01 by Pierre Pronchery | Files touched by this commit (4)
Log message:
Imported php-ssdeep 1.0.2 as security/php-ssdeep

The ssdeep project page describes it as a library for "...computing context
triggered piecewise hashes (CTPH). Also called fuzzy hashes, CTPH can match
inputs that have homologies. Such inputs have sequences of identical bytes in
the same order, although bytes in between these sequences may be different in
both content and length".