./wip/py-decoratortools, Class, function, and metaclass decorators

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.8, Package name: py27-decoratortools-1.8, Maintainer: kamel.derouiche

Want to use decorators, but still need to support Python 2.3?
Wish you could have class decorators, decorate arbitrary assignments,
or match decorated function signatures to their original functions?
Want to get metaclass features without creating metaclasses?
How about synchronized methods?


Required to run:
[devel/py-setuptools] [lang/python27]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: f8876d4e2a744600a51ed126214b9729a713fa5d
RMD160: c4cc286a557588ec4d45ebbbc6d848fdee107a19
Filesize: 28.873 KB

Version history: (Expand)


CVS history: (Expand)


   2014-12-31 14:58:18 by Thomas Klausner | Files touched by this commit (24)
Log message:
Improve EGG_NAME default to work for packages with '-' in their name.
Remove now unnecessary overrides in various packages.

Fix various problems while here, including marking packages as not ready
for python-3.x.
   2012-10-07 13:54:18 by Aleksej Saushev | Files touched by this commit (46)
Log message:
Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.
Mark packages that don't or might probably not have staged installation.
   2010-07-14 15:11:02 by Kamel Derouiche | Files touched by this commit (4) | Imported package
Log message:
Import py26-decoratortools-1.8 as wip/py-decoratortools.

Want to use decorators, but still need to support Python 2.3?
Wish you could have class decorators, decorate arbitrary assignments,
or match decorated function signatures to their original functions?
Want to get metaclass features without creating metaclasses?
How about synchronized methods?