./www/py-beautifulsoup, HTML/XML Parser for Python, version 3

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 3.2.2, Package name: py27-beautifulsoup-3.2.2, Maintainer: pkgsrc-users

Beautiful Soup parses arbitrarily invalid XML- or HTML-like substance
into a tree representation. It provides methods and Pythonic idioms
that make it easy to search and modify the tree.

A well-formed XML/HTML document will yield a well-formed data
structure. An ill-formed XML/HTML document will yield a correspondingly
ill-formed data structure. If your document is only locally
well-formed, you can use this library to find and process the
well-formed part of it. The BeautifulSoup class has heuristics for
obtaining a sensible parse tree in the face of common HTML errors.

This package contains v3 of the module.


Required to run:
[devel/py-setuptools] [lang/python27]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: abf6b21002fb1c74aa786703cd0f8a19ab5b78ee
RMD160: 32fbe7c22c640a483888a7384f1929da5aea82d3
Filesize: 31.938 KB

Version history: (Expand)


CVS history: (Expand)


   2020-07-13 22:05:13 by Thomas Klausner | Files touched by this commit (19)
Log message:
*: reset maintainer for darcy
   2019-11-04 23:10:16 by Roland Illig | Files touched by this commit (243)
Log message:
www: align variable assignments

pkglint -Wall -F --only aligned --only indent -r

Manually excluded phraseanet since pkglint got the indentation wrong.
   2019-10-07 20:34:21 by Adam Ciarcinski | Files touched by this commit (3) | Package updated
Log message:
py-beautifulsoup: updated to 3.2.2

3.2.2:
Added helpful syntax errors when someone tries to run Beautiful Soup 3
code under Python 3. Added a detailed deprecation warning with
instructions for everyone else.
   2019-09-02 15:20:22 by Adam Ciarcinski | Files touched by this commit (415)
Log message:
Changed PYTHON_VERSIONS_INCOMPATIBLE to PYTHON_VERSIONS_ACCEPTED; needed for \ 
future Python 3.8
   2019-04-26 15:14:25 by Maya Rashish | Files touched by this commit (473)
Log message:
Omit mentions of python 34 and 35, after those were removed.

- Includes some whitespace changes, to be handled in a separate commit.
   2018-07-03 07:03:44 by Adam Ciarcinski | Files touched by this commit (495)
Log message:
extend PYTHON_VERSIONS_ for Python 3.7
   2017-09-03 10:53:18 by Thomas Klausner | Files touched by this commit (165)
Log message:
Follow some redirects.
   2017-01-01 15:44:09 by Thomas Klausner | Files touched by this commit (577)
Log message:
Add python-3.6 to incompatible versions.