./www/py-wtforms-alchemy, Generates WTForms forms from SQLAlchemy models

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.17.0, Package name: py37-wtforms-alchemy-0.17.0, Maintainer: pkgsrc-users

Generates WTForms forms from SQLAlchemy models.


Required to run:
[devel/py-setuptools] [databases/py-sqlalchemy] [lang/python27] [lang/py-six] [databases/py-sqlalchemy-utils]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: 2e0f5fd9e78a22dfc5e3aa8acf67080f3c42568c
RMD160: 492950993bf649ae2a0d1f51916d05ede696204b
Filesize: 50.429 KB

Version history: (Expand)


CVS history: (Expand)


   2020-10-03 20:44:56 by Adam Ciarcinski | Files touched by this commit (3) | Package updated
Log message:
py-wtforms-alchemy: updated to 0.17.0

0.17.0:
- Dropped py27, py33 and py34 support

0.16.9:
- Added support for JSON type in TypeMap

0.16.8:
- Fixed QuerySelectField.query allowing no results

0.16.7:
- Fixed UnknownTypeException being thrown correctly for unsupported types

0.16.6:
- Added SQLAlchemy 1.2 support

0.16.5:
- Fixed GroupedQuerySelectMultipleField validator to support empty data

0.16.4:
- Fixed GroupedQuerySelectMultipleField validator

0.16.3:
- Fixed ChoiceType conversion for Enums

0.16.2:
- Added GroupedQueryMultipleSelectField

0.16.1:
- Updated SQLAlchemy-Utils requirement to 0.32.6
- Fixed PhoneNumberType conversion

0.16.0:
- Dropped python 2.6 support
- Made PhoneNumberField work correctly together with DataRequired

0.15.0:
- Moved GroupedQuerySelectField from WTForms-Components package to WTForms-Alchemy
- Moved WeekdaysField from WTForms-Components package to WTForms-Alchemy
- Moved PhoneNumberField from WTForms-Components package to WTForms-Alchemy
- Moved Unique validator from WTForms-Components package to WTForms-Alchemy

0.14.0:
- Added QuerySelectField and QuerySelectMultipleField which were deprecated from
WTForms as of version 2.1

0.13.3:
- Removed ClassMap's inheritance sorting. This never really worked properly and \ 
resulted in weird undeterministic bugs on Python 3.

0.13.2:
- Added support for callables in type map argument

0.13.1:
- Added flake8 checks
- Added isort checks
- Fixed country import caused by SQLAlchemy-Utils 0.30.0
- Update SQLAlchemy-Utils dependency to 0.30.0
   2017-09-16 21:27:31 by Thomas Klausner | Files touched by this commit (372)
Log message:
Reset maintainer
   2016-06-08 19:43:49 by Thomas Klausner | Files touched by this commit (356)
Log message:
Switch to MASTER_SITES_PYPI.
   2015-11-04 03:47:43 by Alistair G. Crooks | Files touched by this commit (758)
Log message:
Add SHA512 digests for distfiles for www category

Problems found locating distfiles:
	Package haskell-cgi: missing distfile haskell-cgi-20001206.tar.gz
	Package nginx: missing distfile array-var-nginx-module-0.04.tar.gz
	Package nginx: missing distfile encrypted-session-nginx-module-0.04.tar.gz
	Package nginx: missing distfile headers-more-nginx-module-0.261.tar.gz
	Package nginx: missing distfile nginx_http_push_module-0.692.tar.gz
	Package nginx: missing distfile set-misc-nginx-module-0.29.tar.gz
	Package nginx-devel: missing distfile echo-nginx-module-0.58.tar.gz
	Package nginx-devel: missing distfile form-input-nginx-module-0.11.tar.gz
	Package nginx-devel: missing distfile lua-nginx-module-0.9.16.tar.gz
	Package nginx-devel: missing distfile nginx_http_push_module-0.692.tar.gz
	Package nginx-devel: missing distfile set-misc-nginx-module-0.29.tar.gz
	Package php-owncloud: missing distfile owncloud-8.2.0.tar.bz2

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-04-14 13:25:38 by Thomas Klausner | Files touched by this commit (8)
Log message:
Remove python-2.6-only package py-ordereddict and references to it.
   2014-12-31 14:57:34 by Thomas Klausner | Files touched by this commit (125)
Log message:
Improve EGG_NAME default to work for packages with '-' in their name.
Remove now unnecessary overrides in various packages.
   2014-11-10 19:36:49 by Blue Rats | Files touched by this commit (2) | Package updated
Log message:
Thought I did this update already...

0.13.0 (2014-10-14)
^^^^^^^^^^^^^^^^^^^

- Made all default validators configurable in model_form_factory
- Added support for disabling default validators

0.12.9 (2014-08-30)
^^^^^^^^^^^^^^^^^^^

- Added support for composite primary keys in ModelFieldList
   2014-08-07 04:32:37 by Blue Rats | Files touched by this commit (2) | Package updated
Log message:
0.12.8 (2014-07-28)
^^^^^^^^^^^^^^^^^^^

- Added support for URLType of SQLAlchemy-Utils

0.12.7 (2014-07-21)
^^^^^^^^^^^^^^^^^^^

- Fix ModelFieldList handling of simultaneous deletes and updates