./www/ruby-faraday_middleware, Various middleware for Faraday

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.1.0, Package name: ruby27-faraday_middleware-1.1.0, Maintainer: tsutsui

Faraday Middleware is a collection of middleware for the Faraday project.


Required to run:
[www/ruby-faraday] [lang/ruby26-base]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: 864a52ea99f896eb9f9546ce56a96aad79a1d2b3
RMD160: c495536e4e6589ba261258c596f7b196c08f231e
Filesize: 16 KB

Version history: (Expand)


CVS history: (Expand)


   2021-09-19 19:49:59 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
www/ruby-faraday_middleware: update to 1.1.0

1.1.0 (2021-07-31)

Features

* Use wrapped exception in Faraday::ParsingError to improve legibility of
  the error (#255, @d-m-u)

Bugs fixed

* Use JSON.generate instead of .dump in request middleware (#266,
  @Be-ngt-oH)

Chores and misc

* Add rubocop-package and drop git ls-files in gemspec (#263, @utkarsh2102)
   2020-06-14 18:27:53 by Takahiro Kambe | Files touched by this commit (3) | Package updated
Log message:
www/ruby-faraday_middleware: update to 1.0.0

Update ruby-faraday_middleware to 1.0.0.

pkgsrc change: add "USE_LANGUAGES=	# none".

1.0.0 (2020-03-29)
This is FaradayMiddleware 1.0 official release!

This release officially supports Faraday 1.0.
It contains all changes included in the 1.0.0.rc1 release, plus:

* Increase minimum rake version to 12.3.3 for security reasons

Special thanks to contributors who helped us push this over the line:
@BobbyMcWho, @onk and @d-m-u

1.0.0.rc1 (2020-02-28)

This is a prerelease. See #200 for details on the shipping plans for 1.0.0.

Changes

* Support Ruby 2.3+.
* Drop support for Faraday v0.7

Bugs fixed

* #198 Autoload an exception class correctly

Chores and misc

* Lint the codebase with RuboCop
* Closed the Wiki and turned it into Markdown files in docs/

0.14.0 (2020-01-10)

NOTE: This is the last minor release in the v0.x series, next release will
be 1.0 to match Faraday v1.0 release and from then on only fixes will be
applied to v0.14.x!

* Fix support for empty bodies having Content-Encoding Gzip (#192)
* RSpec: disable_monkey_patching (#191)
* Add ResponseMiddleware.define_parser unit test (#190)
* Use full URL (url.host + url.request_uri) as cache key (#195)

0.13.1 (2019-02-04)

* Clear Authorization header when redirecting cross-site (#183)
* Brotli is an optional dependency for Gzip (#186)

0.13.0 (2019-01-22)

* Adds support for Brotli decompression of responses (#134)
* Adds support for JSON 2 (#169)
* Hash request URIs before using them as a cache key (#181)
* Remove Addressable::URI query hack (#184)
   2017-09-18 03:07:42 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
www/ruby-faraday_middleware: update to 0.12.2

0.12.2 (2017/08/04)

* Fixes race condition issue with rubygems.org

0.12.1 (2017/08/03)

* Fixes support for Oj < 3.3.3 (#163)
* Adds support for parser_options on MultiXML and SafeYAML parsers

0.12.0 (2017/07/28)

* Replace rash with rash_alt (#136)
* Allow write_options to be specified for FaradayMiddleware::Caching (#155)
* Add support for passing options to JSON.parse (#156)
* Parse YAML safely (#157)
* Handle responses with missing Location header (#159)
* Removes support for ruby < 1.9.3 (#162)
   2017-02-05 11:57:48 by Izumi Tsutsui | Files touched by this commit (4)
Log message:
Import ruby-faraday_middleware-0.11.0.1 as www/ruby-faraday_middleware.

Faraday Middleware is a collection of middleware for the Faraday project.