./www/ruby-rack-cache, HTTP Caching for Rack

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.12.0, Package name: ruby26-rack-cache-1.12.0, Maintainer: pkgsrc-users

HTTP Caching for Rack.


Required to run:
[www/ruby-rack] [lang/ruby26-base]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: 075538655fadfa2dfbd0b57e90ab36fef3b35e2e
RMD160: 67ee475bc95c0f463b618ca68a6d8095679f4d10
Filesize: 28.5 KB

Version history: (Expand)


CVS history: (Expand)


   2020-06-07 17:52:26 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
www/ruby-rack-cache: update to 1.12.0

Update ruby-rack-cache to 1.12.0.

## 1.12.0

 * Add a fault_tolerant flag to fail-over to stale cache
   2020-05-17 18:11:00 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
www/ruby-rack-cache: update to 1.11.1

Update ruby-rack-cache to 1.11.1.

1.11.1 (2020-04-07)

 * when ignoring parts of the query, remove query in key when all
   params are ignored

1.11.0 (2020-01-06)

 * Add a proc to allow ignoring parts of the query string in the key
 CVS: ----------------------------------------------------------------------
   2020-03-20 17:22:32 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
www/ruby-rack-cache: update to 1.11.0

Update ruby-rack-cache to 1.11.0.

pkgsrc change: change dependency from ruby-rack14 to ruby-rack.

## 1.9.0

  * make purge not raise when not implemented
   2018-09-23 19:03:33 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
www/ruby-rack-cache: update to 1.8.0

## 1.8.0 (2018/06/07)

  * Purge key from metastore when entitystore not found
   2017-09-11 17:40:27 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
Update ruby-rack-cache to 1.7.1

1.7.1 (2017/09/06)

* Documentation fix.
* Fix nil warnings.
* Return current date if the Date header is not parseable.
   2017-03-20 16:56:11 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
Update ruby-rack-cache to 1.7.0.

## 1.7.0

  * Meta stores now receive a third ttl argument to write when use_native_ttl is \ 
used.
   2016-03-15 17:18:11 by Takahiro Kambe | Files touched by this commit (3) | Package updated
Log message:
Update ruby-rack-cache to 1.6.1

## 1.6.1

  * Revert 'No longer read responses from cache when we already have them'

## 1.6.0

  * Noop backend
  * No longer read responses from cache when we already have them
  * renamed files from entitystore -> entity_store \ 
(metastore/cachecontrol/appengine) and added warns for old ones
   2015-12-13 17:11:33 by Takahiro Kambe | Files touched by this commit (3) | Package updated
Log message:
Update ruby-rack-cache to 1.5.1.

## 1.5.0

  * only catch StandardError and not Exception

## 1.4.3

  * After overriding the REQUEST_METHOD, store the original request method in \ 
"rack.methodoverride.original_method"

## 1.4.1

  * Ignore invalid Expires date as per RFC

## 1.4.0

  * Not invalidating the cache for preflight CORS request

## 1.3.1 / October 2015

  * Support Ruby 1.9

## 1.3 / Octorber 2015

  * Ruby 2.0 only

  * Gracefully degrade when cache store goes offline

  * allow_reload/revalidate is not enabled by default

  * Make Rack::Cache multithread friendly