./devel/p5-Dist-Zilla, Perl 5 module distribution builder; installer not included

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 6.025, Package name: p5-Dist-Zilla-6.025, Maintainer: pkgsrc-users

Dist::Zilla builds distributions of code to be uploaded to the CPAN.
In this respect, it is like ExtUtils::MakeMaker, Module::Build, or
Module::Install. Unlike those tools, however, it is not also a system for
installing code that has been downloaded from the CPAN. Since it's only
run by authors, and is meant to be run on a repository checkout rather
than on published, released code, it can do much more than those tools,
and is free to make much more ludicrous demands in terms of prerequisites.


Required to run:
[sysutils/p5-File-Copy-Recursive] [textproc/p5-Text-Glob] [textproc/p5-Text-Template] [lang/perl5] [time/p5-DateTime] [devel/p5-File-Find-Rule] [devel/p5-File-HomeDir] [devel/p5-List-MoreUtils] [devel/p5-Params-Util] [devel/p5-Test-Deep] [devel/p5-Path-Class] [devel/p5-PPI] [devel/p5-Term-ReadKey] [converters/p5-JSON] [devel/p5-App-Cmd] [textproc/p5-YAML-Tiny] [devel/p5-Moose] [devel/p5-File-ShareDir] [devel/p5-MooseX-Types] [devel/p5-Data-Section] [devel/p5-Software-License] [devel/p5-MooseX-Types-Path-Class] [devel/p5-Config-INI] [devel/p5-File-pushd] [devel/p5-Perl-Version] [devel/p5-autobox] [devel/p5-Moose-Autobox] [devel/p5-namespace-autoclean] [textproc/p5-String-RewritePrefix] [devel/p5-MooseX-Role-Parameterized] [devel/p5-MooseX-LazyRequire] [devel/p5-Try-Tiny] [devel/p5-Class-Load] [devel/p5-MooseX-SetOnce] [devel/p5-CPAN-Uploader] [devel/p5-Config-MVP] [devel/p5-Hash-Merge-Simple] [devel/p5-File-ShareDir-Install] [textproc/p5-String-Formatter] [textproc/p5-Pod-Eventual] [devel/p5-Config-MVP-Reader-INI] [devel/p5-Sub-Exporter-ForMethods] [devel/p5-Perl-PrereqScanner] [devel/p5-MooseX-Types-Perl] [devel/p5-Log-Dispatchouli] [devel/p5-List-AllUtils] [converters/p5-JSON-MaybeXS] [devel/p5-Term-Encoding] [devel/p5-Term-UI] [archivers/p5-Archive-Tar-Wrapper]

Required to build:
[pkgtools/cwrappers]

Master sites: (Expand)

Filesize: 347.065 KB

Version history: (Expand)


CVS history: (Expand)


   2022-07-16 09:23:15 by Wen Heping | Files touched by this commit (2)
Log message:
Update to 6.025
Remove unneeded TEST_DEPENDS

Upstream changes:
6.025     2022-05-28 11:55:35-04:00 America/New_York
        - eliminate use of multidimensional array emulation
   2022-06-28 13:38:00 by Thomas Klausner | Files touched by this commit (3952)
Log message:
*: recursive bump for perl 5.36
   2021-10-26 12:20:11 by Nia Alarie | Files touched by this commit (3016)
Log message:
archivers: Replace RMD160 checksums with BLAKE2s checksums

All checksums have been double-checked against existing RMD160 and
SHA512 hashes

Could not be committed due to merge conflict:
devel/py-traitlets/distinfo

The following distfiles were unfetchable (note: some may be only fetched
conditionally):

./devel/pvs/distinfo pvs-3.2-solaris.tgz
./devel/eclipse/distinfo eclipse-sourceBuild-srcIncluded-3.0.1.zip
   2021-10-07 15:44:44 by Nia Alarie | Files touched by this commit (3017)
Log message:
devel: Remove SHA1 hashes for distfiles
   2021-10-02 14:42:00 by Wen Heping | Files touched by this commit (2)
Log message:
Update to 6.024
Update DEPENDS

Upstream changes:
6.024     2021-08-01 15:38:44-04:00 America/New_York
        - pass the dist name to Software::License as the program name
          (thanks, Van de Bugger!)
        - create the ArchiveBuilder role for building the archive file
          (thanks, Graham Ollis!)

6.023     2021-07-06 21:37:37-04:00 America/New_York
        - tweak the autoprereqs tests to avoid failing when List::MoreUtils
          (which DZ does not actually need) is not installed)

6.022     2021-06-27 21:36:53-04:00 America/New_York
        - remove dependency on Class::Load, which is not used
        - bump prereq on PPI to 1.222, which is now used in PkgVersion
          (thanks, Dan Book and Sven Kirmess)

6.021     2021-06-27 21:31:21-04:00 America/New_York
        - [ broken release, don't bother ]

6.020     2021-06-14 12:16:09-04:00 America/New_York
        - The log colorization code was trying to use 24-bit color even when
          the installed Term::ANSIColor couldn't support it.  This has been
          fixed by requiring Term::ANSIColor v5.  Thanks, Robert Rothenberg,
          Michael McClimon, and Matthew Horsfall.

6.019     2021-06-13 08:39:14-04:00 America/New_York
        - When using "use_package" in PkgVersion, do not eradicate the \ 
entire
          block of "package NAME BLOCK" syntax!  Wow, what a bug...

6.018     2021-04-03 21:07:54-04:00 America/New_York (TRIAL RELEASE)
        - require perl v5.20.0, now seven years old
        - add Test::CleanNamespaces, clean all namespaces
        - add the same boilerplate of version/pragma/features to every module
        - colorize logger prefix when running in a terminal

6.017     2020-11-02 19:30:21-05:00 America/New_York
        - replace broken 6.016, released from a confused git repo

6.016     2020-11-02 19:27:18-05:00 America/New_York (TRIAL RELEASE)
        - the test generated by [MetaTests] is now an author test, not a
          release test (thanks, Karen Etheridge)
        - UploadToCPAN will now retry (thanks, PERLANCAR)
        - some bug fixes for msys (thanks, Håkon Hægland)
   2021-05-24 21:56:06 by Thomas Klausner | Files touched by this commit (3575)
Log message:
*: recursive bump for perl 5.34
   2020-09-07 01:03:14 by Thomas Klausner | Files touched by this commit (2) | Package updated
Log message:
p5-Dist-Zilla: update to 6.015.

6.015     2020-05-29 14:30:51-04:00 America/New_York
        - add docs for "dzil release -j" (thanks, Jonas B. Nielsen)
        - fix support for dist.pl (why??? 🙂) (thanks, Kent Frederic)
        - remove unnecessary check for Pod::Simple being loaded (Dave Lambley)
   2020-08-31 20:13:29 by Thomas Klausner | Files touched by this commit (3631)
Log message:
*: bump PKGREVISION for perl-5.32.