./graphics/py-fits, Python module for reading, writing, and manipulating FITS files

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 3.5nb1, Package name: py37-fits-3.5nb1, Maintainer: kamelderouiche

FITS (Flexible Image Transport System) is a data format most used in astronomy.
PyFITS is a Python module for reading, writing, and manipulating FITS files.
The module uses Python's object-oriented features to provide quick, easy, and
efficient access to FITS files. The use of Python's array syntax enables
immediate access to any FITS extension, header cards, or data items.


Required to run:
[devel/py-setuptools] [math/py-numpy] [lang/python37]

Required to build:
[pkgtools/cwrappers] [devel/py-d2to1] [devel/py-stsci.distutils]

Master sites:

SHA1: efc7e6158b054adc3edf73c89d556bb368d475b8
RMD160: 730ef34939162752af0c6478345dc45c81204210
Filesize: 1650.821 KB

Version history: (Expand)


CVS history: (Expand)


   2020-10-12 23:52:05 by Jason Bacon | Files touched by this commit (87) | Package updated
Log message:
math/blas, math/lapack: Install interchangeable BLAS system

Install the new interchangeable BLAS system created by Thomas Orgis,
currently supporting Netlib BLAS/LAPACK, OpenBLAS, cblas, lapacke, and
Apple's Accelerate.framework.  This system allows the user to select any
BLAS implementation without modifying packages or using package options, by
setting PKGSRC_BLAS_TYPES in mk.conf. See mk/blas.buildlink3.mk for details.

This commit should not alter behavior of existing packages as the system
defaults to Netlib BLAS/LAPACK, which until now has been the only supported
implementation.

Details:

Add new mk/blas.buildlink3.mk for inclusion in dependent packages
Install compatible Netlib math/blas and math/lapack packages
Update math/blas and math/lapack MAINTAINER approved by adam@
OpenBLAS, cblas, and lapacke will follow in separate commits
Update direct dependents to use mk/blas.buildlink3.mk
Perform recursive revbump
   2020-05-25 07:29:32 by Roland Illig | Files touched by this commit (1)
Log message:
graphics/py-fits: remove nonexistent file from REPLACE_PYTHON
   2018-10-07 10:51:42 by Adam Ciarcinski | Files touched by this commit (4) | Package updated
Log message:
py-fits: updated to 3.5

3.5:
This release officially deprecates PyFITS. Please use astropy.io.fits instead.
- Importing PyFITS now gives deprecation warning.
- Documentation updates.
   2017-11-16 00:29:26 by Mark Davies | Files touched by this commit (1)
Log message:
graphics/py-fits: add python2 only entries to PLIST
   2017-09-30 12:10:04 by Adam Ciarcinski | Files touched by this commit (3) | Package updated
Log message:
py-fits: update to 3.4

3.4:
This release removes support for Python 2.5, as well as Python 3.0 - 3.2.
Supported Python versions are now Python 2.6, 2.7, and 3.3+.  This
release incorporates new features and bug fixes made in the
``astropy.io.fits`` module in Astropy, which is originally based on PyFITS
and supersedes the stand-alone PyFITS module.

This will likely be the last stand-alone release of PyFITS that does not
depend on Astropy.  There are a few reasons for this:

1) Development resources for PyFITS are limited, and better focused on
   newer projects.

2) Astropy incorporates all features of PyFITS, and has many new features
   from which future development of the FITS reader/writer can benefit, such
   as a better table interface, units, and datetime types.  Since the most
   beneficial future development in ``astropy.io.fits`` depends on other
   parts of Astropy there is less motivation to maintain an independent FITS
   module.

This release contains most changes to the ``astropy.io.fits`` module that
have been made since the last release of PyFITS (v3.3), except for changes
that depend explicitly on other parts of Astropy.  This brings PyFITS mostly
to parity with the version of ``astropy.io.fits`` that will be in Astropy
v1.1.2.
   2016-08-28 19:47:47 by Thomas Klausner | Files touched by this commit (1)
Log message:
Remove build dependency that is implied by stsci.distutils.
   2016-08-28 17:39:25 by Thomas Klausner | Files touched by this commit (1)
Log message:
Add missing BUILD_DEPENDS and remove BROKEN.
   2016-06-08 19:43:49 by Thomas Klausner | Files touched by this commit (356)
Log message:
Switch to MASTER_SITES_PYPI.