./misc/orca, Screen reader

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 3.34.1nb6, Package name: orca-3.34.1nb6, Maintainer: pkgsrc-users

Orca is a free, open source, flexible, and extensible screen reader
that provides access to the graphical desktop via user-customizable
combinations of speech, braille, and/or magnification.


Required to run:
[sysutils/desktop-file-utils] [sysutils/py-dbus] [graphics/hicolor-icon-theme] [devel/glib2] [x11/gtk3] [devel/py-gobject3] [devel/py-at-spi2] [sysutils/gsettings-desktop-schemas] [devel/libwnck3] [multimedia/gstreamer1] [multimedia/py-gstreamer1] [audio/speech-dispatcher] [lang/python37]

Required to build:
[pkgtools/x11-links] [x11/xcb-proto] [x11/fixesproto4] [devel/py-gobject3-common] [pkgtools/cwrappers] [x11/xorgproto]

Master sites: (Expand)

Filesize: 3572.582 KB

Version history: (Expand)


CVS history: (Expand)


   2022-03-12 09:01:53 by Nia Alarie | Files touched by this commit (82)
Log message:
*: Replace per-package msgfmt hacks with msgfmt-desktop.mk
   2022-03-12 08:14:17 by Nia Alarie | Files touched by this commit (4)
Log message:
misc: Use hacks.mk to avoid NetBSD msgfmt on NetBSD only.
   2021-12-08 17:07:18 by Adam Ciarcinski | Files touched by this commit (3063)
Log message:
revbump for icu and libffi
   2021-11-15 23:54:34 by Thomas Klausner | Files touched by this commit (396)
Log message:
*: recursive bump for gstreamer 1.18.5
   2021-10-26 12:59:39 by Nia Alarie | Files touched by this commit (378)
Log message:
misc: Replace RMD160 checksums with BLAKE2s checksums

All checksums have been double-checked against existing RMD160 and
SHA512 hashes

The following distfiles could not be fetched (possibly fetched
conditionally?):

./misc/libreoffice/distinfo libreoffice/harfbuzz-2.6.4.tar.xz
   2021-10-07 16:35:55 by Nia Alarie | Files touched by this commit (378)
Log message:
misc: Remove SHA1 hashes for distfiles
   2021-05-02 12:24:53 by Nia Alarie | Files touched by this commit (56)
Log message:
*: Use the tools framework for itstool

Now it should be more obvious when a package needs it as a dependency,
as it will fail loudly if it isn't declared as a tool.

While here, some duplicate dependencies on itstool were removed from the
MATE packages
   2020-12-04 21:45:51 by Nia Alarie | Files touched by this commit (456)
Log message:
Revbump packages with a runtime Python dep but no version prefix.

For the Python 3.8 default switch.