./security/ruby-rex-encoder, Polymorphic encoders that Metasploit uses for payload encoding

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.1.5, Package name: ruby26-rex-encoder-0.1.5, Maintainer: minskim

This library provides the basis for all of the polymorphic encoders
that Metasploit uses for payload encoding. Encoders are used to try
and create a version of a payload that is free of bad characters as
defined by the exploit.


Required to run:
[devel/ruby-metasm] [security/ruby-rex-text] [security/ruby-rex-arch] [lang/ruby26-base]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: 1f48b3f83655bcea8113948b3e8ea7394fe10b87
RMD160: eee11ff1a148262a4585109175376f62d14cd94b
Filesize: 40 KB

Version history: (Expand)


CVS history: (Expand)


   2021-02-05 16:07:10 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
security/ruby-rex-core: update to 0.1.15

0.1.5 (2020-11-30)

* update spec to require Ruby 2.2.0 or greater
   2020-06-21 16:54:51 by Takahiro Kambe | Files touched by this commit (13)
Log message:
Add "USE_LANGUAGES=	# noen"

Add "USE_LANGUAGES=	# noen" for pure Ruby packages.
   2017-10-13 20:51:42 by Min Sik Kim | Files touched by this commit (4)
Log message:
security/ruby-rex-encoder: Import version 0.1.4

This library provides the basis for all of the polymorphic encoders
that Metasploit uses for payload encoding. Encoders are used to try
and create a version of a payload that is free of bad characters as
defined by the exploit.