./security/ruby-rex-rop_builder, Ruby Exploitation Library for building ROP chains

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.1.4, Package name: ruby26-rex-rop_builder-0.1.4, Maintainer: minskim

This is the Ruby Exploitation(Rex) Library for building ROP chains. It
also comes with the msfrop command line tool.


Required to run:
[devel/ruby-metasm] [security/ruby-rex-text] [security/ruby-rex-core] [lang/ruby26-base]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: c56ecd8c55ec6d2704d1664d81e7410d1fe36cdf
RMD160: e6e1fbe7e58fe1568d34fdbe36f0dee095b29b23
Filesize: 17.5 KB

Version history: (Expand)


CVS history: (Expand)


   2021-02-05 16:28:07 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
security/ruby-rex-rop_builder: update to 0.1.4

0.1.4 (2020-11-30)

* update spec to require Ruby 2.2.0 or greater
* relax dev bundle and update authors …
	- Allows bundle with latest bundler
	- Updates authors to reflect current maintainers
	- Update travis to test with 2.7.2
* Land #1, Update gemspec
   2020-06-21 16:54:51 by Takahiro Kambe | Files touched by this commit (13)
Log message:
Add "USE_LANGUAGES=	# noen"

Add "USE_LANGUAGES=	# noen" for pure Ruby packages.
   2017-10-13 20:39:13 by Min Sik Kim | Files touched by this commit (5)
Log message:
security/ruby-rex-rop_builder: Import version 0.1.3

This is the Ruby Exploitation(Rex) Library for building ROP chains. It
also comes with the msfrop command line tool.