./devel/accerciser, Interactive Python accessibility explorer for the GNOME desktop

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 3.34.0, Package name: accerciser-3.34.0, Maintainer: prlw1

Accerciser is an interactive Python accessibility explorer for the
GNOME desktop. It uses AT-SPI2 to inspect and control widgets,
allowing you to check if an application is providing correct
information to assistive technologies and automated test frameworks.
Accerciser has a simple plugin framework which you can use to create
custom views of accessibility information.

In essence, Accerciser is a next generation at-poke tool.


Required to run:
[sysutils/desktop-file-utils] [graphics/hicolor-icon-theme] [devel/glib2] [x11/py-Xlib] [x11/gtk3] [devel/py-ipython] [devel/at-spi2-core] [devel/py-gobject3] [devel/py-at-spi2] [devel/libwnck3] [lang/python37]

Required to build:
[pkgtools/x11-links] [x11/xcb-proto] [x11/fixesproto4] [textproc/itstool] [devel/py-gobject3-common] [pkgtools/cwrappers] [x11/xorgproto]

Master sites: (Expand)

SHA1: 3f695a450d012b852f6384ce0de18483864dca9e
RMD160: dcc90ebbffb5dc0bd0ac878258c4b339ccae4531
Filesize: 2749.387 KB

Version history: (Expand)


CVS history: (Expand)


   2020-01-19 00:36:14 by Roland Illig | Files touched by this commit (3046)
Log message:
all: migrate several HOMEPAGEs to https

pkglint --only "https instead of http" -r -F

With manual adjustments afterwards since pkglint 19.4.4 fixed a few
indentations in unrelated lines.

This mainly affects projects hosted at SourceForce, as well as
freedesktop.org, CTAN and GNU.
   2019-11-03 11:39:32 by Roland Illig | Files touched by this commit (274)
Log message:
devel: align variable assignments

pkglint -Wall -F --only aligned --only indent -r

No manual corrections.
   2019-10-26 14:53:26 by Kamil Rytarowski | Files touched by this commit (1)
Log message:
accerciser: Set PREV_PKGPATH
   2019-10-25 16:13:23 by Kamil Rytarowski | Files touched by this commit (4)
Log message:
devel/accerciser: import accerciser-3.34.0

Accerciser is an interactive Python accessibility explorer for the
GNOME desktop. It uses AT-SPI2 to inspect and control widgets,
allowing you to check if an application is providing correct
information to assistive technologies and automated test frameworks.
Accerciser has a simple plugin framework which you can use to create
custom views of accessibility information.

In essence, Accerciser is a next generation at-poke tool.
   2019-07-02 06:04:34 by Adam Ciarcinski | Files touched by this commit (4) | Package removed
Log message:
accerciser: removed, use accerciser3 instead
   2019-04-26 16:12:50 by Maya Rashish | Files touched by this commit (205)
Log message:
fix some whitespace, mostly introduced in the previous
python 3.4 / 3.5 removal commit.
   2019-04-26 15:14:25 by Maya Rashish | Files touched by this commit (473)
Log message:
Omit mentions of python 34 and 35, after those were removed.

- Includes some whitespace changes, to be handled in a separate commit.
   2019-04-25 09:33:32 by Maya Rashish | Files touched by this commit (620)
Log message:
PKGREVISION bump for anything using python without a PYPKGPREFIX.

This is a semi-manual PKGREVISION bump.