./meta-pkgs/bulk-large, Meta-package for a standard largish limited bulk build

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 20200911, Package name: bulk-large-20200911, Maintainer: dholland

This package contains a largish number of packages selected to be
maximally useful for bulk building. It is intended to take about a
day to build on a reasonably modern machine.


Required to build:
[sysutils/dbus-glib] [sysutils/dbus] [textproc/aspell] [print/cups] [print/lilypond] [www/clearsilver] [graphics/graphviz] [graphics/gimp] [graphics/blender] [editors/xemacs-packages] [editors/abiword] [editors/emacs-packages] [audio/taglib] [lang/ocaml] [math/octave] [math/R] [cross/avr-gdb] [cross/avr-gcc] [cross/avr-libc] [security/heimdal] [security/mit-krb5] [mail/roundcube] [mail/evolution] [mail/squirrelmail] [mail/thunderbird] [meta-pkgs/windowmaker-desktop] [meta-pkgs/pkg_developer] [meta-pkgs/pkgsrc-guide-tools] [meta-pkgs/netbsd-www] [meta-pkgs/gnustep] [meta-pkgs/netbsd-doc-print] [meta-pkgs/xfce4] [meta-pkgs/xfce4-extras] [meta-pkgs/netbsd-doc] [devel/gmp] [devel/libgetopt] [x11/xview] [mail/claws-mail] [www/mediawiki] [misc/zyGrib] [comms/asterisk16] [editors/p5-Padre] [mail/thunderbird-l10n] [databases/db5] [filesystems/tahoe-lafs] [filesystems/glusterfs] [security/mit-krb5-appl] [meta-pkgs/modular-xorg] [devel/heirloom-libcommon] [textproc/FlightCrew] [devel/py-gobject3] [multimedia/gstreamer1] [multimedia/gst-plugins1-base] [meta-pkgs/deforaos-desktop] [meta-pkgs/bulk-small] [meta-pkgs/bulk-medium] [x11/qt5-qttools] [x11/qt5-qtbase] [multimedia/mpv] [pkgtools/cwrappers] [meta-pkgs/texlive-collection-latex] [meta-pkgs/texlive-collection-basic] [meta-pkgs/texlive-collection-basic-doc] [meta-pkgs/texlive-collection-latex-doc] [meta-pkgs/texlive-collection-fontsrecommended-doc] [meta-pkgs/texlive-collection-fontsrecommended] [net/libsoup] [databases/postgresql95] [meta-pkgs/mate] [print/atril] [databases/mysql57-client] [databases/mysql57-server] [editors/emacs25] [meta-pkgs/texlive-collection-plaingeneric] [www/ruby-rails51] [lang/python37] [chat/quassel] [www/ruby-rails52] [www/ruby-rails60]

Version history: (Expand)


CVS history: (Expand)


   2020-09-10 17:44:50 by Takahiro Kambe | Files touched by this commit (1)
Log message:
meta-pkgs/bulk-large: -ruby-rails51

* Drop www/ruby-rails51.
   2020-04-30 17:54:04 by Maya Rashish | Files touched by this commit (1)
Log message:
bulk-large: remove the older mysql of the two so this package can be built
by non-pbulk users. remove valgrind because it's rejecting my OS/arch combo
and is probably not a sufficiently portable package. bump version.
   2020-03-21 21:28:42 by Tobias Nygren | Files touched by this commit (1)
Log message:
bulk-large: -ruby-rails42 +ruby-rails60
   2020-03-13 11:41:12 by Nia Alarie | Files touched by this commit (1)
Log message:
bulk-large: Attempt to build fewer deprecated/obsolete packages.

Use logical replacements where possible - e.g, mpv is the more-common-now
fork of mplayer, quassel is now a more popular Qt IRC client than
Konversation and has more overlap with other packages on this list, etc.

Bump version
   2019-09-24 14:22:46 by Sevan Janiyan | Files touched by this commit (1)
Log message:
asterisk package has been removed, use latest version instead
   2019-09-15 22:34:49 by David H. Gutteridge | Files touched by this commit (1)
Log message:
bulk-large: fix atril version pattern string
   2019-09-15 02:11:45 by Nia Alarie | Files touched by this commit (1) | Package updated
Log message:
bulk-large: Update to 20190915

Obsolete packages:
- evince, replaced with atril
- gstreamer0, replaced with gstreamer1
- py-gtk2, replaced with py-gobject3
- qt4, replaced with qt5
   2019-09-02 15:20:22 by Adam Ciarcinski | Files touched by this commit (415)
Log message:
Changed PYTHON_VERSIONS_INCOMPATIBLE to PYTHON_VERSIONS_ACCEPTED; needed for \ 
future Python 3.8